July 09, 2010

Create a World fix for Game Update 1.14/2.9/3.5/4.2

The Create a World Tool that is compatible with update 1.14/2.9/3.5/4.2 and Ambitions is now available. Please uninstall your old version of Create a World.